Author Topic: General iOS issues  (Read 1367 times)

zach

  • Newbie
  • *
  • Posts: 8
    • View Profile
General iOS issues
« on: June 21, 2015, 06:13:23 pm »
It seems that my issues with getting my game to run on iOS had nothing to do with my game.  I can't get any of the sample scenes to run on device either.  I do get different errors depending on the build settings I choose, but I consistently get errors in the native plug-in when running on device.  I'm using Unity 5.1.0f3 and LiquidPhysics 1.3.  Are there very specific build settings required, or is this just an issue in the current build?

Physical_Liquid_Conor

  • Administrator
  • Full Member
  • *****
  • Posts: 208
    • View Profile
Re: General iOS issues
« Reply #1 on: June 22, 2015, 12:27:25 pm »
Hi zach,

Some users are still experiencing difficulty getting the plugin to work on iOS. I'm currently looking into this problem. Could you please post which version of XCode and LLVM you are using to build the project? Are you changing any build settings after exporting the project from Unity? Are you building in release mode or debug?

zach

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: General iOS issues
« Reply #2 on: June 22, 2015, 03:06:42 pm »
I am using Xcode 6.3.2.  I believe it is LLVM 6.1.  I am not changing any build settings after exporting from Unity.  I tried both debug and release builds, and had the same results.  Yesterday I spent a few hours trying to get the samples to work in an empty project, and had the same results.  I tried quite a few combinations of export settings from Unity.  I tried both the IL2CPP back end as well as the mono export option.

Physical_Liquid_Conor

  • Administrator
  • Full Member
  • *****
  • Posts: 208
    • View Profile
Re: General iOS issues
« Reply #3 on: June 22, 2015, 05:26:40 pm »
Apple require you to submit 64 bit apps now so you must use the IL2CPP export option when building for iOS.

I am currently on XCode 6.3 so I will update to 6.3.2 and try to reproduce the error. It might be a case where the lib file from 6.3 is not compatible with 6.3.2 for some reason. I'll get back to you when I know.

Physical_Liquid_Conor

  • Administrator
  • Full Member
  • *****
  • Posts: 208
    • View Profile
Re: General iOS issues
« Reply #4 on: June 25, 2015, 05:04:14 pm »
Hi,
Please take a look at this thread to see the current status on the iOS plugin. You should be able to get it to work now.

Annabef

  • Newbie
  • *
  • Posts: 32
    • View Profile
General iOS issues
« Reply #5 on: June 24, 2016, 10:59:58 pm »
Curious as to which VM software you are using? I was running VMware fusionĀ on my Mac Pro tower at work on Yosemite and experienced the same issues you had. Once I removed VMware everything was normal again.

___
XRumer 12.0.17 + SocPlugin: Most popular soft for advertisement in social networks